Issues accessing CompanyCam on Web and Mobile
Incident Report for CompanyCam
Resolved
This incident has been resolved. You may need to refresh or sign out and sign back in. Please reach out to CompanyCam Support via chat or email at support@companycam.com if you are still having issues.
Posted Aug 21, 2024 - 12:00 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 21, 2024 - 11:51 CDT
Investigating
We are currently investigating this issue.
Posted Aug 21, 2024 - 11:41 CDT
This incident affected: Web App and Mobile App.