Background work is delayed: Integrations sync is delayed

Incident Report for CompanyCam

Resolved

Background work delay is moving back to normal levels. Team will continue monitor. Though resolving this occurrence of this issue.
Posted Apr 02, 2026 - 15:10 CDT

Monitoring

Background work is catching up. Team is monitoring for signs of increasing delays.
Posted Apr 02, 2026 - 13:58 CDT

Identified

Known affected services:

- Dropbox/Sharepoint/Pipedrive sync is delayed
- Google calendar syncing is delayed
- Recap Emails are delayed
- Certain counts in the app aren't been updated
Posted Apr 02, 2026 - 13:56 CDT
This incident affected: Integrations.