Issues accessing the Help Center and AI Actions.

Incident Report for CompanyCam

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:06 CST

Investigating

The 3rd-party provider (Cloudflare) is experiencing an outage that may affect access to our Help Center and AI actions.
Posted Nov 18, 2025 - 08:44 CST
This incident affected: Web App and Mobile App.