Issue impacting the ability to contact CompanyCam Support.
Incident Report for CompanyCam
Resolved
The incident with our communications service has been resolved. We're now working to reach back out to Users as quickly as possible!
Posted May 29, 2024 - 11:59 CDT
Identified
We're experiencing an issue with our chat and email program which is preventing communication with our Support Team. The service we use is aware of the issue and we hope to be back online soon. In the meantime you can send a message to support@companycam.com and we'll answer you as soon as we're able!
Posted May 29, 2024 - 10:32 CDT