Issues loading the Project feed on the web

Incident Report for CompanyCam

Resolved

This incident has been resolved. Please get in touch with our Support team if you're still experiencing issues. Thank you for your patience as we worked through this!
Posted Mar 02, 2026 - 12:37 CST

Monitoring

The cause has been identified, and performance is stable. We’re monitoring closely and will update if anything changes.
Posted Mar 02, 2026 - 11:59 CST

Investigating

We are currently investigating an issue affecting the main Project feed on the web app. We will provide updates here as we learn more.
Posted Mar 02, 2026 - 11:33 CST
This incident affected: Web App.