Degraded performance/lag on the mobile and web apps

Incident Report for CompanyCam

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 15:23 CST

Monitoring

Performance has stabilized, and we’re continuing to monitor closely to ensure consistent behavior. We'll share updates if anything changes.
Posted Jan 08, 2026 - 13:28 CST

Update

Response times are beginning to improve, though some users may still experience intermittent issues. Our team continues to investigate and work toward full stability.
Posted Jan 08, 2026 - 13:05 CST

Investigating

We are currently investigating an issue affecting the mobile and web apps. Customers may experience degraded performance or app lag. We will provide updates here as we learn more.
Posted Jan 08, 2026 - 12:15 CST
This incident affected: Web App and Mobile App.