Increased latency affecting some web app Users

Incident Report for CompanyCam

Update

This issue remains under investigation. While it is impacting users globally, the behavior is intermittent, and some users may only experience brief periods of degraded performance, including slow page loads or timeouts. Most functionality remains stable and available, allowing users to continue completing their work. Our team is actively working toward a solution and will continue to post updates.
Posted Dec 17, 2025 - 09:04 CST

Update

Our team is continuing to investigate the issue while closely monitoring web app stability. We’ll provide updates as more information becomes available.
Posted Dec 16, 2025 - 08:05 CST

Update

We’re actively monitoring reported cases and web app stability and will share updates here as our investigation continues.
Posted Dec 15, 2025 - 17:38 CST

Investigating

We are currently investigating an issue affecting some Users on the web. Customers may experience increased latency when loading Projects, photos, etc. We will provide updates here as we learn more.
Posted Dec 15, 2025 - 15:17 CST
This incident affects: Web App.