Degraded performance for CompanyCam's Signature feature due to a provider issue

Incident Report for CompanyCam

Resolved

Dropbox has implemented a fix and is monitoring the results. If you continue to experience issues, please contact our Support Team through the in-app chat or by email at support@companycam.com.
Posted Oct 01, 2025 - 13:01 CDT

Investigating

We've identified an issue causing degraded performance of CompanyCam's Signature feature. This stems from a larger issue with one of our providers, Dropbox. We will keep you updated on the status of this issue. Please reach out via chat or email if you have further questions!
Posted Oct 01, 2025 - 09:48 CDT
This incident affected: Web App and Mobile App.