Degraded performance of CompanyCam on web and mobile.

Incident Report for CompanyCam

Resolved

CompanyCam should now be functioning as expected as the greater AWS issues are resolved. If you're still having trouble please reach out via the in-app chat or email at support@companycam.com.
Posted Oct 20, 2025 - 16:52 CDT

Update

We are now seeing improvement in the stability of our mobile and web apps and will continue to monitor this issue closely.

As these outages are also impacting other services users may experience delays when trying to contact CompanyCam's Support Team, so we'd encourage you to opt into notifications here.
Posted Oct 20, 2025 - 13:17 CDT

Monitoring

We are continuing to experience degradation from the continued major outage affecting Amazon Web Services (AWS) in the US-East-1 region.

Amazon has issued an update indicating that have identified a cause and are working to resolve the issue, but there is currently no ETA.

As these outages are also impacting other services Users may experience delays when trying to contact CompanyCam's Support Team, so we'd encourage you to opt into notifications here.
Posted Oct 20, 2025 - 11:24 CDT

Update

Users are unable to access CompanyCam via the app and the web or are experiencing extreme slowness when doing so. We've confirmed these issues are impacted by larger AWS outages. As these outages are also impacting other services Users may experience delays when trying to contact CompanyCam's Support Team, so we'd encourage you to opt into notifications here.
Posted Oct 20, 2025 - 10:33 CDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:05 CDT

Identified

Users are experience slowness when accessing CompanyCam via the app and the web. We've confirmed these issues are impacted by larger AWS outages and will continue to monitor and provide updates.
Posted Oct 20, 2025 - 08:33 CDT
This incident affected: Web App and Mobile App.