Issues loading CompanyCam
Incident Report for CompanyCam
Resolved
The issues loading CompanyCam on the web and app are resolved. Please reach out to support@companycam.com if you're still experiencing any problems.
Posted Jan 24, 2023 - 09:12 CST
Identified
Users are experiencing issues loading CompanyCam on the web and are receiving 504 errors. The cause of the issue is being investigated.
Posted Jan 24, 2023 - 08:44 CST
This incident affected: Web App and Mobile App.