Delays impacting downloading photos
Incident Report for CompanyCam
Resolved
The delays downloading photos from CompanyCam has been resolved and downloads should be processing as expected. Please reach out to support@companycam.com if you're still having issues!
Posted May 04, 2023 - 13:25 CDT
Identified
Photos downloads are currently delayed, we're working on remedying the underlying issue, but all requested downloads will be received.
Posted May 04, 2023 - 13:07 CDT
This incident affected: Web App and Mobile App.