Admin and Manager users cannot rename, duplicate, or delete Advanced Checklists (web + mobile)

Incident Report for CompanyCam

Resolved

Advanced Checklists should be abled to renamed, duplicated, deleted by Admins and Managers now.

Close/reopen the mobile app. Or 'refresh' on web.
Posted Sep 03, 2026 - 15:19 CDT

Identified

We believe that we have found the source of the issue. Working on the fix.
Posted Sep 03, 2026 - 15:06 CDT
This incident affected: Web App and Mobile App.