Intermittent Errors and Degraded Performance on the Mobile and Web Apps

Incident Report for CompanyCam

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 12:06 CST

Update

This issue has been resolved and performance has returned to normal. Thanks for your patience while we worked through this.
Posted Dec 29, 2025 - 12:06 CST

Monitoring

A fix has been implemented, and performance is improving. We’re monitoring closely to ensure stability. We’ll provide additional updates if anything changes.
Posted Dec 29, 2025 - 11:33 CST

Identified

We’ve identified the cause of the issue and are working on a fix. Users may still experience intermittent slowdowns or errors while remediation is underway.
Posted Dec 29, 2025 - 11:12 CST

Investigating

We’re investigating an issue causing errors and degraded performance across parts of the app. Some users may experience latency or errors when loading pages or performing actions. Our team is actively working on a resolution, and we’ll provide updates as progress is made.
Posted Dec 29, 2025 - 10:57 CST
This incident affected: API, Web App, and Mobile App.