Issues accessing CompanyCam on Web and Mobile
Incident Report for CompanyCam
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 12:20 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2024 - 12:18 CDT
Investigating
We are currently investigating this issue.
Posted Mar 19, 2024 - 12:18 CDT
This incident affected: Web App and Mobile App.