Issues creating, accessing and exporting Checklists

Incident Report for CompanyCam

Resolved

Our team as resolved two issues impacting the ability of Users to accessing and utilize Checklists and Checklist Templates. If you're still having trouble please contact us via the in-app chat or email us at support@companycam.com.
Posted Sep 24, 2025 - 14:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2025 - 12:39 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 24, 2025 - 12:12 CDT

Investigating

We are currently investigating an issue preventing Users from accessing and utilizing Checklists and Checklist Templates as expected. This issue is impacting Users on both the mobile and web apps.
Posted Sep 24, 2025 - 12:11 CDT
This incident affected: Web App and Mobile App.