Issues creating Projects and adding Users on App and Web

Incident Report for CompanyCam

Resolved

This incident has been resolved. Users should now be able to create Projects and send invites without issue. All Projects created during the degradation should now appear in your feed. Similarly any invites sent should now be sent.

If you're still having issues please reach out to support@companycam.com.
Posted Oct 22, 2025 - 15:31 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2025 - 14:17 CDT

Identified

The cause of the issue impacting creating Projects and adding Users has been identified and we're actively working on a fix.
Posted Oct 22, 2025 - 13:34 CDT

Investigating

We are currently investigating an issue preventing Users from creating Projects and inviting Users. This issue is impacting Users on both the mobile and web apps.
Posted Oct 22, 2025 - 13:04 CDT
This incident affected: Web App and Mobile App.