App Degradation

Incident Report for CompanyCam

Resolved

The issue affecting data loading has been resolved, and the app is now functioning normally. All information should be loading as expected.
Posted Jul 28, 2026 - 07:33 CDT

Investigating

We’re currently investigating an issue causing data to not load in the app. Some users may have issues fetching data.

Our team is working to restore normal functionality. We apologize for the disruption and will provide another update as more information becomes available.
Posted Jul 28, 2026 - 07:20 CDT
This incident affected: Web App and Mobile App.