Users are reporting problems downloading photos on the Web app

Incident Report for CompanyCam

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 16:35 CDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 25, 2026 - 16:18 CDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 25, 2026 - 16:05 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 25, 2026 - 15:39 CDT

Investigating

We are currently investigating this issue.
Posted Aug 25, 2026 - 15:22 CDT
This incident affected: Web App.