App is down / unresponsive

Incident Report for CompanyCam

Resolved

App has been operating as expected for last few hours. We will continue our post-incident actions to reduce the likelihood of this happening in the future.
Posted Jul 15, 2026 - 15:17 CDT

Update

The photo / uploads queue is caught up and behaving normally. We will continue to monitor the situation.
Posted Jul 15, 2026 - 10:47 CDT

Monitoring

The app is up in a degraded performance state (delayed photo / background work). We will continue to monitor the situation.
Posted Jul 15, 2026 - 10:36 CDT

Update

App is recovering but photo upload/processing seems delayed. We're continuing our investigation.
Posted Jul 15, 2026 - 10:09 CDT

Investigating

The app is down and unresponsive. We are investigating.
Posted Jul 15, 2026 - 10:04 CDT
This incident affected: API, Web App, Uploads & Processing, Search, Mobile App, Integrations, and Notifications.