Site Outage
Incident Report for CompanyCam
Resolved
This incident has been resolved. Please contact the Support Team if you're still experiencing issues.
Posted Jun 28, 2022 - 14:46 CDT
Investigating
We're experiencing unexpected site down time. We are working to address the issue as quickly as possible.

Please subscribe to updates, you will receive any new information.
Posted Jun 28, 2022 - 14:25 CDT
This incident affected: API, Web App, Uploads & Processing, Search, and Mobile App.